Difference between revisions of "VbzCart/queries/qryCache Flow Procs"

from HTYP, the free directory anyone can edit if they can prove to me that they're not a spambot
Jump to navigation Jump to search
m (moved VbzCart/queries/v data flow to VbzCart/queries/qryCache Flow Queries: using more canonical naming convention)
(history and sql updates)
Line 2: Line 2:
 
* '''Purpose''': compiles caching data for quicker processing
 
* '''Purpose''': compiles caching data for quicker processing
 
* '''Requires''': {{vbzcart|table|cache_flow}}, {{vbzcart|table|cache_queries}}
 
* '''Requires''': {{vbzcart|table|cache_flow}}, {{vbzcart|table|cache_queries}}
* '''Used by''': store page display routines (need to be more specific...)
+
* '''Used by''': cache manager
 
* '''History''':
 
* '''History''':
** '''2010-11-09''' Renamed tables, so had to fix this query
+
** '''2010-11-09''' Renamed tables, so had to fix this query; renamed from v_data_flow to qryCache_Flow_Queries
 
==SQL==
 
==SQL==
<section begin=sql /><mysql>CREATE OR REPLACE VIEW v_data_flow AS
+
<section begin=sql /><mysql>CREATE OR REPLACE VIEW qryCache_Flow_Queries AS
 
   SELECT
 
   SELECT
 
     df.ID_Srce,
 
     df.ID_Srce,

Revision as of 19:44, 9 November 2010

About

  • Purpose: compiles caching data for quicker processing
  • Requires: cache_flow, cache_queries
  • Used by: cache manager
  • History:
    • 2010-11-09 Renamed tables, so had to fix this query; renamed from v_data_flow to qryCache_Flow_Queries

SQL

<mysql>CREATE OR REPLACE VIEW qryCache_Flow_Queries AS

 SELECT
   df.ID_Srce,
   df.ID_Dest,
   df.ID_Proc,
   dfx.doesClear
 FROM cache_flow AS df LEFT JOIN cache_queries AS dfx ON df.ID_Proc=dfx.ID
 ORDER BY dfx.doesClear;</mysql>