ownCloud/client/install error

from HTYP, the free directory anyone can edit if they can prove to me that they're not a spambot
Jump to: navigation, search

Starting with an error-free apt repository and owncloud not installed, apt-get install owncloud-client results in this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libowncloudsync0 libqtkeychain0 owncloud-client-l10n
The following NEW packages will be installed:
  libowncloudsync0 libqtkeychain0 owncloud-client owncloud-client-l10n
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1,678 kB of archives.
After this operation, 6,254 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously unselected package libqtkeychain0:amd64.
(Reading database ... 375931 files and directories currently installed.)
Preparing to unpack .../libqtkeychain0_0.5.0-1build1~gcc5.1_amd64.deb ...
Unpacking libqtkeychain0:amd64 (0.5.0-1build1~gcc5.1) ...
Preparing to unpack .../libowncloudsync0_2.1.1-1.1_amd64.deb ...
ln: failed to create symbolic link ‘/etc/ownCloud/sync-exclude.lst.dpkg-tmp’: File exists
dpkg: error processing archive /var/cache/apt/archives/libowncloudsync0_2.1.1-1.1_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Selecting previously unselected package owncloud-client-l10n.
Preparing to unpack .../owncloud-client-l10n_2.1.1-1.1_all.deb ...
Unpacking owncloud-client-l10n (2.1.1-1.1) ...
Selecting previously unselected package owncloud-client:amd64.
Preparing to unpack .../owncloud-client_2.1.1-1.1_amd64.deb ...
Unpacking owncloud-client:amd64 (2.1.1-1.1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu3) ...
Processing triggers for mime-support (3.58ubuntu1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libowncloudsync0_2.1.1-1.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

This is what happens when I type apt-get -f install after an unsuccessful attempt to install libowncloudsync0:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libowncloudsync0
The following NEW packages will be installed:
  libowncloudsync0
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/374 kB of archives.
After this operation, 1,242 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 376046 files and directories currently installed.)
Preparing to unpack .../libowncloudsync0_2.1.1-1.1_amd64.deb ...
ln: failed to create symbolic link ‘/etc/ownCloud/sync-exclude.lst.dpkg-tmp’: File exists
dpkg: error processing archive /var/cache/apt/archives/libowncloudsync0_2.1.1-1.1_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libowncloudsync0_2.1.1-1.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Tentatively: it's trying to install two copies of libowncloudsync0. Note that it's listed both "extra packages" and "NEW packages".

At this point, apt-get remove owncloud-client produces the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 owncloud-client-l10n : Depends: owncloud-client (>= 2.1.1-1.1) but it is not going to be installed
                        Depends: libowncloudsync0 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Here's what happens when I try to apt-get remove libowncloudsync0:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'libowncloudsync0' is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 owncloud-client : Depends: libowncloudsync0 (= 2.1.1-1.1) but it is not going to be installed
 owncloud-client-l10n : Depends: libowncloudsync0 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

At this point, the only way to get out of the loop is to install the old version of libowncloudsync, "libowncloudsync0.5", using Synaptic (which notes that owncloud-client and owncloud-client-l10n also need to be removed). This somehow fixes things and you can start over.