2007-07-27 ComicGenesis problem

from HTYP, the free directory anyone can edit if they can prove to me that they're not a spambot
Jump to: navigation, search

The Problem

This shows what seems to be happening to cause some browsers to be unable to access the proper content of http://catandmouse.comicgenesis.com :

woozle@gonzo:~/Scratch$ wget http://catandmouse.comicgenesis.com/
--13:54:41--  http://catandmouse.comicgenesis.com/
           => `index.html'
Resolving catandmouse.comicgenesis.com... 66.117.154.119
Connecting to catandmouse.comicgenesis.com|66.117.154.119|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://catandmouse.comicgenesis.com/start.php?homepage=true [following]
--13:54:42--  http://catandmouse.comicgenesis.com/start.php?homepage=true
           => `start.php?homepage=true'
Connecting to catandmouse.comicgenesis.com|66.117.154.119|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]

    [ <=>                                                      ] 15            --.--K/s

13:54:42 (505.12 KB/s) - `start.php?homepage=true' saved [15]

woozle@gonzo:~/Scratch$

"302 Found" is an http status code indicating "The requested resource resides temporarily under a different URI. Since the redirection might be altered on occasion, the client SHOULD continue to use the Request-URI for future requests. This response is only cacheable if indicated by a Cache-Control or Expires header field." [1] However, the content at the redirected URI is clearly not the requested content (try it even in MS Windows), this is an inappropriate code being issued by the server at comicgenesis.com.

2007-10-21 Update

Apparently CG has started blocking wget, which adds a sprinkling of difficulty to the diagnostic process, but the following gets around that:

wget --header="User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20061201 Firefox/2.0.0.6 (Ubuntu-feisty)" http://catandmouse.comicgenesis.com

Example of proper result (Gonzo):

--14:43:54--  http://catandmouse.comicgenesis.com/
           => `index.html'
Resolving catandmouse.comicgenesis.com... 66.220.2.20
Connecting to catandmouse.comicgenesis.com|66.220.2.20|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5,643 (5.5K) [text/html]

100%[=========================================================>] 5,643          9.59K/s

14:43:57 (9.59 KB/s) - `index.html' saved [5643/5643]

Example of bad result (Floyd):

--14:47:35--  http://catandmouse.comicgenesis.com/
           => `index.html'
Resolving catandmouse.comicgenesis.com... 66.117.154.119
Connecting to catandmouse.comicgenesis.com|66.117.154.119|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://catandmouse.comicgenesis.com/start.php?homepage=true [following]
--14:47:37--  http://catandmouse.comicgenesis.com/start.php?homepage=true
           => `start.php?homepage=true'
Connecting to catandmouse.comicgenesis.com|66.117.154.119|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]

    [ <=>                                                      ] 15            --.--K/s

14:47:38 (636.89 KB/s) - `start.php?homepage=true' saved [15]

The problem seems to be that the domain name (catandmouse.comicgenesis.com) is being resolved to the wrong IP address:

  • 66.220.2.20 - good
  • 66.117.154.119 - bad