2007-08-24 theage.com.au problem

from HTYP, the free directory anyone can edit if they can prove to me that they're not a spambot
Revision as of 02:43, 25 August 2007 by Woozle (talk | contribs) (New page: category:tech notes <pre> <TehWuzyl> What might cause web browsers on different machines to get different results from trying to access the same web site? <TehWuzyl> Trying to access t...)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
<TehWuzyl> What might cause web browsers on different machines to get different results from trying to access the same web site?
<TehWuzyl> Trying to access theage.com.au from Gonzo, I get a page with the words "It worked!" and nothing else...
<TehWuzyl> ...but other machines on the network (one Linux, one Windows, both using Firefox) accessed what looks like the proper site.
<TehWuzyl> And we've had a problem with a ComicGenesis-hosted site, although that may or may not be related. But it's equally mysterious.
<TehWuzyl> Ok, I've just tried it with Konqueror on Gonzo, and I get the same results as Firefox. So it seems to be machine-related.
<TehWuzyl> On gonzo, www.theage.com.au resolves to 216.234.246.150 = 96.f6.ead8.static.theplanet.com; on Mokey (where I get the proper site), it resolves to either 203.26.51.42 or 203.58.234.68.
<TehWuzyl> ...with no associated domain name, and the pings don't return.
<TehWuzyl> Is there any way to figure out what DNS servers are being used to resolve a domain name?
<TehWuzyl> nslookup says the "server" for Gonzo is 166.70.63.3, which seems to be at xmission.com, which is where it is supposed to be...
<TehWuzyl> nslookup on Bunsen says the server is Gonzo, which is also correct... but why would Gonzo give a different answer than what it gets?
<TehWuzyl> I restarted dnsmasq, and now the address is resolving properly -- but I'm still getting the wrong page on firefox. And Konqueror.

The two web pages I have tried loading are: